Heater not working

Engine Oily Bits, Ignition, Fuelling, Cooling, Exhaust, etc.
Post Reply
Message
Author
Ltriumph
Newbie
Newbie
Posts: 19
Joined: Thu Nov 26, 2015 1:51 am

Heater not working

#1 Post by Ltriumph » Sun Jul 16, 2017 8:26 pm

I went for a ride yesterday and found the heater not warming up (winter in NZ) - MK2 2000TC. What could be causing that? Would appreciate your input.

User avatar
Dave B
Senior Member
Senior Member
Posts: 827
Joined: Thu Dec 27, 2007 8:37 pm
Location: Wigan,Home of the mighty Warriors

Re: Heater not working

#2 Post by Dave B » Sun Jul 16, 2017 8:48 pm

Assuming that the engine is getting up to normal operating temperature, the first thing I would try is a flush/backflush of the heater matrix. Disconnect the two heater hoses at the bulkhead and attach a garden hose to one of the two stubs of the heater matrix. After a minute or so connect the hose to the other stub and flush it the other way. You'll be suprised at the amount of cr*p that comes out! Repeat a few times in either direction until the water runs clear.
Try that and let us know how you get on :wink:
Club Member 2035
1970 2500 Mk2 in pimento red
1972 2000 Mk2 in sapphire blue
Vauxhall Omega 3.0 Elite
Vauxhall Vectra C Design lpg
Vauxhall Insignia SE

johnnydog
Senior Member
Senior Member
Posts: 586
Joined: Tue May 14, 2013 12:33 pm
Location: Lancashire

Re: Heater not working

#3 Post by johnnydog » Sun Jul 16, 2017 8:58 pm

I would hazard a guess that possibly the solid cable from the heater control for the interior temperature that goes to the water valve on the offside (drivers side in the UK), has come way from its mounting clamp as a result of the water valve seizing. It's probably seized in the 'cold' position therefore not allowing coolant to circulate through the heater matrix. Bit of a fiddle to get to, but doable without removing too much trim - removing the drivers parcel shelf make access better. If you can free it off / get the valve out, a touch of Vaseline or rubber grease on reassembly will help prevent it sticking again.
If the heater control knob feels 'slacker' than normal, then this is a good indication that the valve has seized and the cable has pulled away.
N.B. This is assuming it is a MK2.....the MK1 is a lot easier to access from the engine bay, but isn't as prone to seizing like the MK2.
Register Member no. 1596

1967 Mk1 2000 in Gunmetal Grey
1969 Mk1 2000 in Royal Blue
1970 Mk2 2000 in Valencia Blue
1972 Mk2 2.5 PI in Triumph White
1973 Mk2 2.5 PI in Sienna Brown
1976 Mk2 2500S in Carmine Red

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest