Light switch not connecting

Batteries, Alternator, Wiring, Lighting, etc. (Please discuss ignition problems in the Engine category)
Post Reply
Message
Author
Ltriumph
Groupie
Groupie
Posts: 32
Joined: Thu Nov 26, 2015 1:51 am
Location: NZ

Light switch not connecting

#1 Post by Ltriumph » Sun Feb 25, 2018 6:37 am

Hi - went for a WOF (MOT) today. For the first time ever the lights wouldn't go, I moved the switch around a bit and finally they went. It appears they now have to be in the exact spot to go. How should I approach fixing it? Lose wire or light switch? MkII 2000 TC 1978.
Triumph TC 2000 1978
Triumph Tiger 800 2012

Charles H
Senior Member
Senior Member
Posts: 1358
Joined: Mon Jan 15, 2007 2:38 pm
Location: Folkestone

Re: Light switch not connecting

#2 Post by Charles H » Sun Feb 25, 2018 11:59 am

Most likely is the rotary light switch. Contact cleaner and exercise or replacement switch.
Charles Harrison
Register member 3095
Folkestone
Cherry Red Mk1 2000 Rally Car
Mallard Blue 2.5PI
Sapphire Blue GT6 Mk3
Vermillion Red Spitfire 1500
Pimento Red TR6
Pimento Red Stag
Inky Blue VW Passat B5.5
Arctic Blue Jaguar XJ40

Ltriumph
Groupie
Groupie
Posts: 32
Joined: Thu Nov 26, 2015 1:51 am
Location: NZ

Re: Light switch not connecting

#3 Post by Ltriumph » Sun Feb 25, 2018 10:56 pm

Thanks for your reply. I have had a look at the manual but can't see how to get the round knob off, and get to the switch. Do you have to take off the steering surround?
Triumph TC 2000 1978
Triumph Tiger 800 2012

Charles H
Senior Member
Senior Member
Posts: 1358
Joined: Mon Jan 15, 2007 2:38 pm
Location: Folkestone

Re: Light switch not connecting

#4 Post by Charles H » Mon Feb 26, 2018 10:52 am

Yes, take the shroud off, three cross head screws from underneath which reveals the switch.
Charles Harrison
Register member 3095
Folkestone
Cherry Red Mk1 2000 Rally Car
Mallard Blue 2.5PI
Sapphire Blue GT6 Mk3
Vermillion Red Spitfire 1500
Pimento Red TR6
Pimento Red Stag
Inky Blue VW Passat B5.5
Arctic Blue Jaguar XJ40

User avatar
Dave B
Senior Member
Senior Member
Posts: 857
Joined: Thu Dec 27, 2007 8:37 pm
Location: Wigan,Home of the mighty Warriors

Re: Light switch not connecting

#5 Post by Dave B » Mon Feb 26, 2018 5:18 pm

To get the rotary switch knob off, insert something like a 1/8" drill bit or a small dia. screwdriver into the hole in the bottom of the switch knob to depress the plunger holding the knob to the switch spindle. You might then be able to spray some switch cleaner along the spindle and into the switch. Operate the switch on and off a couple of dozen times whilst doing so and that should cure it.
Club Member 2035
1970 2500 Mk2 in pimento red
1972 2000 Mk2 in sapphire blue
Vauxhall Omega 3.0 Elite
Vauxhall Vectra C Design lpg
Vauxhall Insignia SE (Now been lpg'd)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest