Alternators and batteries

Batteries, Alternator, Wiring, Lighting, etc. (Please discuss ignition problems in the Engine category)
Post Reply
Message
Author
User avatar
johnconradlee
Senior Member
Senior Member
Posts: 347
Joined: Thu Jan 01, 1970 12:33 am
Location: Havant, Nr Portsmouth, England

Alternators and batteries

#1 Post by johnconradlee » Fri Nov 06, 2015 1:14 pm

LuLU been running a bit rough the last couple of months, not liked starting from cold, hot not much better, wouldn't idle consistently, running really lumpily and down on power. I was blaming the winter plus the slightly ropey condition of my distributor and was wondering if I needed to look at the carb diaphragms as she seemed a bit gutless Driving down to Devon the other week.
Anyway, couple of nights ago the stater motor was a bit slugish (but she still started) so I thought with the short journeys at night I'd done that week at night I'd probably flattened the battery a bit so took it out of the car and put it on charge.
Put the battery back in the car last night and basically seem to have fixed all of the above issues. Idles nicely, even the slight misfire has gone, starts easier, picks up better, frankly like a different car.

I'm now wondering why my battery isn't charging properly. It's obviously charging at bit, but the ignition light glows dimly at idle with the (halogen) headlights on. With the direct to battery bypassing the ammeter wire removed so I get a reading I don't seem to be getting much charging below about 2000 rpm so I'm wondering if a smaller pulley would help.

The alternator is a Lucas 18ACR equivalent supplied by Chris Witor circa December 2012 so I'd be irritated if it's failing already. The battery is of a similar age but a bit on the small side as a Varta 063 as opposed to the recommended "biggest one that will fit" 096 but I would have thought should still be ok.
John Lee

1966 Triumph 2000 Mk1 "LuLU" (the Lee family Triumph) - various shades of Green - Currently on SORN. Requires the engine sorting and a bit of bodywork (blooming rust! :evil: ).

User avatar
Alec
Senior Member
Senior Member
Posts: 2367
Joined: Sat Feb 07, 2004 7:23 pm
Location: Oswestry, Shropshire

Re: Alternators and batteries

#2 Post by Alec » Fri Nov 06, 2015 9:49 pm

Hello John,

I don't believe the battery capacity is relevant, (I'm not an believer of the bigger the better philosophy) as that only means that you have greater cranking capacity. If the car is in good order that is not really that important.

There seems to be a problem if your general indication seems as though the charge rate is low. Initially I would check connections are sound but it is possible that the alternator is below par. Do you have a meter with which you can check the voltage. Also don't forget the simple check of belt tension or condition? I don't feel that you need to look at pulley diameter.

Alec
0465

MK1.5 2.5 P.I.
Jaguar MK 2 (Long term restoration.)
Hymer 564 Motorhome.
Jaguar X Type Estate 2.5

User avatar
CAR
Senior Member
Senior Member
Posts: 2782
Joined: Wed Jan 16, 2008 7:40 am
Location: Doncaster, South Yorkshire

Re: Alternators and batteries

#3 Post by CAR » Sat Nov 07, 2015 5:58 pm

a loose or dirty connection at the battery terminals would do the same too John.

Colin
Colin and Amanda Radford
Register Show Organisers and Directors
'75'N' 2500S CARMINE ESTATE France easter'09, RBRR'10,'12. TEAM 48 RBRR'16 'HOE'
'71'J' 2.5PI VALENCIA SALOON France easter'10, RBRR'14 'FRanK'
'69'G' VALENCIA SALOON c/w BMW 2.5 24valve and 5spd box 'JO'

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest