Ignition light

Batteries, Alternator, Wiring, Lighting, etc. (Please discuss ignition problems in the Engine category)
Post Reply
Message
Author
CP Sargent
Groupie
Groupie
Posts: 55
Joined: Sun May 20, 2012 10:49 pm
Location: Fordham Ely Cambs

Ignition light

#1 Post by CP Sargent » Sun Sep 27, 2015 8:24 pm

Hi mk1 starts fine and runs good but at 65/70mph the ignition light flickers on and off but dosent effect running , it has a new battery and a new coil fitted any one have any ideas on what to check , look for cheers Pete
1967 yellow mk1 saloon
1968 damson vitesse convertible
1970 valenica blue herald saloon]
1990 red Fiat 126

tony
Senior Member
Senior Member
Posts: 756
Joined: Sun Jun 14, 2009 5:35 am
Location: New Zealand

Re: Ignition light

#2 Post by tony » Mon Sep 28, 2015 3:11 am

Suggest the dynamo/alternator needs an overhaul.
Tony.
1976 2500 TC. converted to S specs.

Lots of bits

1999 BMW Z3.
2006 BMW 325ti.
Hopefully not needing too many bits.




.

Charles H
Senior Member
Senior Member
Posts: 1437
Joined: Mon Jan 15, 2007 2:38 pm
Location: Folkestone

Re: Ignition light

#3 Post by Charles H » Mon Sep 28, 2015 8:44 am

Agree with the above, however if you are still running a dynamo, it could be the control box which is low down on the front offside in under the air box intake pipes. :)
Charles Harrison
Register member 3095
Folkestone
Cherry Red Mk1 2000 Rally Car
Mallard Blue 2.5PI
Sapphire Blue GT6 Mk3
Vermillion Red Spitfire 1500
Pimento Red TR6
Pimento Red Stag
Inky Blue VW Passat B5.5
Arctic Blue Jaguar XJ40

User avatar
CAR
Senior Member
Senior Member
Posts: 2782
Joined: Wed Jan 16, 2008 7:40 am
Location: Doncaster, South Yorkshire

Re: Ignition light

#4 Post by CAR » Mon Sep 28, 2015 11:42 am

could even be as simple as a fanbelt loose. Difficult to hear at higher revs.
Colin and Amanda Radford
Register Show Organisers and Directors
'75'N' 2500S CARMINE ESTATE France easter'09, RBRR'10,'12. TEAM 48 RBRR'16 'HOE'
'71'J' 2.5PI VALENCIA SALOON France easter'10, RBRR'14 'FRanK'
'69'G' VALENCIA SALOON c/w BMW 2.5 24valve and 5spd box 'JO'

Mike Stevens
Site Admin
Site Admin
Posts: 3462
Joined: Mon May 08, 2006 9:50 pm
Location: South Oxfordshire, UK

Re: Ignition light

#5 Post by Mike Stevens » Mon Sep 28, 2015 12:08 pm

If you have an alternator, most likely the brushes have worn. They seem to do about 70k miles before giving trouble.

If a dynamo, then as Charles says, you need to look at the regulator, although it could still be the brushes!

Cheers,
Mike.
(South Oxfordshire)
Register Member No 0355
1971 2.5PI Saloon Sapphire blue
1973 2.5PI Saloon rust some Honeysuckle
1973 Stag French blue
(1949 LandRover was blue should be light green!)

CP Sargent
Groupie
Groupie
Posts: 55
Joined: Sun May 20, 2012 10:49 pm
Location: Fordham Ely Cambs

Re: Ignition light

#6 Post by CP Sargent » Mon Sep 28, 2015 6:24 pm

Hi all thanks for replies , the car is running a alternator which was on the car when I got it about 3 yeers ago so don't know much about it , will have a look when I get some time
1967 yellow mk1 saloon
1968 damson vitesse convertible
1970 valenica blue herald saloon]
1990 red Fiat 126

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest